Forum: Forums topas RSS
Jedit - Ta button not working
FredMarlton #1
Member since Jul 2018 · 19 posts
Group memberships: Members
Show profile · Link to this post
Subject: Jedit - Ta button not working
Hi all,

We're having some trouble with installing all the relevant add-ons in Jedit for Topas. Everything appears to be fine after carrying out all of the steps 1-5 from the instructions from the Durham page, but the Ta buttom isn’t opening Topas.

When typing a command, such as the following: "C:\Topas-6\ta.exe" in the Jedit console Topas opens just fine, but the Ta button isn't doing this.

This is on a computer with different users. For the first Jedit installation everything worked fine, but this problem has come up for another user.

Any help is much appreciated.

Thanks,
Fred
johnsoevans (Administrator) #2
User title: John Evans
Member since Aug 2009 · 224 posts
Group memberships: Administrators, Members
Show profile · Link to this post
I've not come across this before.  My guess is that it's to do with having a multi user computer.  The button accesses macros which get stored in a .user directory by default.  You may have to install jEdit for all users or point to the right macros directory.  You can check where it's looking via the utilities/settings directory menu.

What should happen:

Pressing on the TA button should run a macro called TArun.bsh which sits in one of your .jedit folders. 

On my computer it's at:

C:\Users\username\.jedit\macros

Things to try:

1. Do you have that directory?

1.5 Is jEdit looking in that directory (utilities/settings directory)?

2. The same macro can be run from the jEdit macros menu.  Does that work?

3. What happens if you try type c:\topas_directory\ta.exe in the console window?

4. Check that the toolbar TA icon is pointing to the right place.  In jEdit go to utilities/global options/tool bar.  Select the TA icon.  Click on the little "spanner" icon.  Check that it links to the "TARun" macro.
FredMarlton #3
Member since Jul 2018 · 19 posts
Group memberships: Members
Show profile · Link to this post
Hi John,

Thanks for the reponse. We did all those checks below and only had a problem with no.4. The buttons didn't come up at all in the when going through those menus, even though they appeared in the window.

However, after having a play around with it, we got it working.

This was achieved by copying the .jedit folder from my account to the other user account.

Don't know why or how, but it's working, so hopefully nothing else comes up

Fred
johnsoevans (Administrator) #4
User title: John Evans
Member since Aug 2009 · 224 posts
Group memberships: Administrators, Members
Show profile · Link to this post
That was going to be my next suggestion (honest).  Glad it's working.
rowlesmr #5
Member since Oct 2011 · 203 posts
Group memberships: Members
Show profile · Link to this post
Another way to check is to write

jEdit.getProperty("ta.main.dir")

into the BeanShell in jEdit. It will tell you the directory it is trying to go to in order to run Topas.

If you want to change it, then try

jEdit.setProperty("ta.main.dir", "C:\\TA6")

or some other directory.
--
Matthew
FredMarlton #6
Member since Jul 2018 · 19 posts
Group memberships: Members
Show profile · Link to this post
So, I've managed to come up with a new problem somehow....

When setting up Jedit for other users on the same computer I still have the same problem of the Ta button not opening Topas.

When I did the following step that I wrote in a previous post: "This was achieved by copying the .jedit folder from my account to the other user account. " I now have a new problem. Jedit will now open on my user account, but not for the account that is currently logged in.... If anyone knows how to fix this then that would be greatly appreciated :)

Thanks,
Fred
rowlesmr #7
Member since Oct 2011 · 203 posts
Group memberships: Members
Show profile · Link to this post
Have you tried my suggestion?
--
Matthew
FredMarlton #8
Member since Jul 2018 · 19 posts
Group memberships: Members
Show profile · Link to this post
Hi Matt,

Thanks for the response. Sorry for my slow response, dry-July up here (reference to work, not alcohol consumption). Tried your suggestion and it didn't make any difference unfortunately.

This is going to sound really strange, what i did next time was run the inp-setup.bsh macro without doing the previous step of copying across the jars. The Topas buttons in the toolbar weren't working and then all of sudden they were.... The only thing that happened in between was going to Utilities/Settings Directory and then checking where things were pointing to....And then when going to Macros I noticed they all appeared.... I had a witness so that I could track what happened and we were both befuddled.

However, we've run into a new error. Everything on his jedit runs really slowly..... We'll play around some more and see where we went wrong....

Sorry for all these lame posts guys.

Thanks,
Fred
FredMarlton #9
Member since Jul 2018 · 19 posts
Group memberships: Members
Show profile · Link to this post
Hi all,

So, a PhD student here worked out the solution to this and we've been able to repeat it on other users accounts. Hopefully this is useful for others in the future.

After doing steps 4 and 5 in the "Setting up jEdit 4.3 to use with Topas" page the buttons still weren't working.

The fix was to click on: Macros -> Rescan Macros

And just like magic, it worked after that.


Fred
Close Smaller – Larger + Reply to this post:
Verification code: VeriCode Please enter the word from the image into the text field below. (Type the letters only, lower case is okay.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Special characters:
Go to forum
Not logged in. · Lost password · Register
This board is powered by the Unclassified NewsBoard software, 20120620-dev, © 2003-2011 by Yves Goergen
Current time: 2020-01-24, 12:30:42 (UTC +00:00)